Unable to delete asset from discussion thread

jwvanderbeck's Avatar

jwvanderbeck

03 Dec, 2009 04:08 PM

I am the owner/admin of my Tender site, yet when I try to delete an attached file from a discussion thread, it asks me if I want to delete the asset permanently, and I say yes, then i'm brought to a page that says:

The change you wanted was rejected.

Maybe you tried to change something you didn't have access to.

There shouldn't be anything I don't have access to :P

  1. 1 Posted by rick on 03 Dec, 2009 06:15 PM

    rick's Avatar

    Which asset on which discussion? Is it any discussion or a specific one?

  2. 2 Posted by jwvanderbeck on 03 Dec, 2009 06:26 PM

    jwvanderbeck's Avatar

    I just tried with another attachment. I posted a reply to an old thread, and attached a file. I then waited for the processing to be completed, and then attempted to delete the asset.

    This time I did not get the error message. In fact I got nothing at all after clicking OK on the prompt. I tried a second time to delete it, got the prompt again and clicked OK, then it took me to a Page Not Found error.

    It now appears that the attachment has been deleted but it is still showing on the thread as an attachment.

    I went back to the original thread that was the problem and tried to delete the attachment again, and got the same error as mentioned in the original post.

    This post is the one giving me the permissions error

    This post is the one I just did as a test that now has an orphan attachment.

  3. 3 Posted by rick on 03 Dec, 2009 07:43 PM

    rick's Avatar

    I have a small fix that should be coming out later today for this. It looks like an odd caching issue on our part -- not really a permissions issue. Apologies for the lame bug... :)

  4. 4 Posted by jwvanderbeck on 03 Dec, 2009 07:48 PM

    jwvanderbeck's Avatar

    Excellent news. Thank you.

  5. 5 Posted by jwvanderbeck on 03 Dec, 2009 07:49 PM

    jwvanderbeck's Avatar

    >
    > Will the fix also fix the orphaned one?
    >

  6. 6 Posted by rick on 03 Dec, 2009 07:52 PM

    rick's Avatar

    Yup, it doesn't show up for me anymore. I'm pretty sure I was able to
    clear it up.

  7. 7 Posted by rick on 03 Dec, 2009 07:56 PM

    rick's Avatar

    Er, just to be clear: I manually fixed up the two discussions you linked. Future discussions will have issues until I roll the fix out.

  8. 8 Posted by jwvanderbeck on 07 Dec, 2009 05:36 AM

    jwvanderbeck's Avatar

    I can delete assets now, but they still have the "orphan" issue where the page still shows the attachment as being present, but when you click on it it shows a page not found error.

  9. 9 Posted by rick on 07 Dec, 2009 07:34 AM

    rick's Avatar

    Ah yea, I just now pushed the fix for that :) It should be all good now. Thanks again for your feedback on this.

  10. rick closed this discussion on 07 Dec, 2009 07:34 AM.

Discussions are closed to public comments.
If you need help with Tender please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac