Remote Authentication Form Posting Doesn't Provide Rich Info(i.e. email)

Corey Donohoe's Avatar

Corey Donohoe

26 Feb, 2009 04:01 PM

You can see this here, http://community-support.engineyard.com/discussions/problems/3-my-display-name-is-not-correct-in-community-support. Both Jeremy and I posted when authenticated via the tender cookies, our email address doesn't show up.

There's also no way to log out, clicking on 'Not You' doesn't do it.

  1. Support Staff 1 Posted by Courtenay on 26 Feb, 2009 07:11 PM

    Courtenay's Avatar

    Hey Corey,

    Use this alternate version of the plugin. You basically just add tender_name to the end of the signed string.

    http://github.com/courtenay/tender_multipass/tree/master

    Set the tender_name cookie (make sure it's in the hmac) and you can set whatever profile name you want.

  2. Support Staff 2 Posted by Courtenay on 26 Feb, 2009 07:11 PM

    Courtenay's Avatar

    user.tender_multipass(cookies, 1.week.from_now.to_i, :full_name)

    instead of

    user.tender_multipass(cookies, 1.week.from_now.to_i)

  3. 3 Posted by atmos on 26 Feb, 2009 09:03 PM

    atmos's Avatar

    Hey Courtenay,

    I added the tender_name cookie and I'm still not getting a username displayed when posting to forms. I've done the clear my cookies and start over dance a few times in different browsers and I'm not seeing any change.

  4. Support Staff 4 Posted by Courtenay on 27 Feb, 2009 01:43 AM

    Courtenay's Avatar

    You have to actually sign the tender_name. Try doing it with the redirect link instead of the cookie.

  5. 5 Posted by atmos on 27 Feb, 2009 04:13 PM

    atmos's Avatar

    Yo,

    I've gotten a few other people to try this and it looks like perhaps you guys cache this info locally the first time a user hit the site? If that's the case then I think we're good, it just keeps putting everything before the @ symbol in my email address as my full name.

    Is there any way to logout when using this remote authentication?

  6. 6 Posted by kamal on 27 Feb, 2009 05:42 PM

    kamal's Avatar

    I can confirm that the user's name is not being picked up for display. Instead, the user's email is used instead in the top header ("Logged in as [email blocked]") and the name set to foo (anonymous).

    I am using Courtenay's tender_multipass fork.

  7. Support Staff 7 Posted by Courtenay on 28 Feb, 2009 03:27 AM

    Courtenay's Avatar

    OK guys, I've fixed this .. please confirm that it's all working.

    Also, there probably should be a "logout" link that's user customizable that takes you to your original app...? What do you think?

  8. 8 Posted by kamal on 28 Feb, 2009 03:53 AM

    kamal's Avatar

    The name is correctly displayed in the issue. The top-right "Logged in as ..." still shows the email instead of the name. Is this by design?

    I also tested adding the additional params - tender_external_id, tender_external_url but am not seeing this exposed in Tender's UI.

    +1 for having the logout option.

  9. 9 Posted by System on 28 Feb, 2009 04:06 AM

    System's Avatar

    A Lighthouse ticket was created for this discussion

  10. 10 Posted by System on 28 Feb, 2009 04:07 AM

    System's Avatar

    A Lighthouse ticket was created for this discussion

  11. Support Staff 11 Posted by Courtenay on 28 Feb, 2009 04:07 AM

    Courtenay's Avatar

    I've opened a few dev tickets for these issues (logged-in as, tender_external, and logout). We'll verify and fix as necessary.

  12. 12 Posted by System on 28 Feb, 2009 04:08 AM

    System's Avatar

    A Lighthouse ticket was created for this discussion

  13. 13 Posted by System on 06 Mar, 2009 11:43 PM

    System's Avatar

    Ticket # 285 was resolved by Kyle Neath.

  14. 14 Posted by System on 06 Apr, 2009 05:53 AM

    System's Avatar

    Ticket # 287 was resolved by rick.

  15. Nicole closed this discussion on 10 Dec, 2009 08:47 PM.

Discussions are closed to public comments.
If you need help with Tender please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

14 Oct, 2019 04:05 AM
14 Oct, 2019 12:43 AM
21 Sep, 2019 02:33 PM
27 Aug, 2019 05:35 PM
15 Aug, 2019 01:56 AM