Truncated URLs in Code Blocks

Thomas Bukowski's Avatar

Thomas Bukowski

17 Mar, 2009 03:55 AM

Hello, I've taken a look at https://help.tenderapp.com/discussions/problems/380-how-to-escape-an-url, but it looks like URLs are still truncated in code blocks:

Test
https://help.tenderapp.com/discussions/problems/380-how-to-escape-an-url
Test

Thanks, thomas.

  1. 1 Posted by Thomas Bukowski on 02 Apr, 2009 11:40 AM

    Thomas Bukowski's Avatar

    Hello,

    I think I wasn't particularly clear. I'm wondering if there's any way of avoiding shortened URLs in code blocks. We host our documentation on Tender, and installation instructions in particular would benefit from full-length URLs, since they would be cut-and-paste compatible.

    I might have missed some trick to achieve this with markdown. If not, a reply would be great!

    Thank you,

    thomas.

  2. 2 Posted by rick on 02 Apr, 2009 01:25 PM

    rick's Avatar

    You can put quotes around it, or use a markdown link:

    "https://help.tenderapp.com/discussions/problems/380-how-to-escape-an-url"

    Here is how you escape a URL [escape a URL](...)

  3. 3 Posted by Thomas Bukowski on 02 Apr, 2009 10:41 PM

    Thomas Bukowski's Avatar

    That works for inline links, but can URLs inside code blocks also be untruncated? By code block, I mean several lines prefixed with four spaces:

    script/plugin install http://newrelic.rubyforge.org/svn/newrelic_rpm
    

    Since it's a code block, neither the quote trick nor the markdown link works, and the link gets truncated.

  4. 4 Posted by Michael Bleigh on 24 Apr, 2009 03:37 PM

    Michael Bleigh's Avatar

    +1 to fixing this. It is a nightmare for writing REST API docs.

    In fact, why is any markdown processed in code blocks at all? Inside the indented area there should be no processing whatsoever other than escaping HTML entities.

    Also escaping it via [http://myurl.com/](http://myurl.com) doesn't work, at least in the context in which I tried it.

  5. 5 Posted by System on 01 May, 2009 11:30 PM

    System's Avatar

    A Lighthouse ticket was created for this discussion

  6. 6 Posted by Kyle Neath (Git... on 01 May, 2009 11:30 PM

    Kyle Neath (GitHub Staff) 's Avatar

    I think we'll take a look at how to disable the autolink inside code blocks. It's starting to get a bit annoying on our end too.

  7. 7 Posted by rick on 27 May, 2009 06:23 AM

    rick's Avatar

    Thomas: I've fixed the issue, but I had to modify your example a bit. The autolinker still picks up URLs in the markdown code blocks. It's preferable if you use the @@@ syntax to specify the code blocks so that the parser can recognize it and process it outside of markdown and the autolinker.

  8. 8 Posted by rick on 27 May, 2009 06:47 AM

    rick's Avatar

    Okay, so the @@@ syntax is not required. The custom formatter now doesn't run the autolinker or markdown formatters on any pre-formatted content.

  9. Nicole closed this discussion on 10 Dec, 2009 09:00 PM.

Discussions are closed to public comments.
If you need help with Tender please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

05 Dec, 2019 01:11 AM
22 Nov, 2019 01:04 PM
14 Oct, 2019 04:05 AM
14 Oct, 2019 12:43 AM
21 Sep, 2019 02:33 PM