Don't include drafts when exporting KB

Christophe 's Avatar


01 Dec, 2014 09:12 AM


we are regularly using the "Export your KB" tool to give some of our customers an off line version of our doc. and we just discovered that draft articles are included in the generated pdf which is a bit annoying.

Could you please hide these articles? (may be they could be included with the help of an option)



  1. 1 Posted by Julien on 01 Dec, 2014 03:31 PM

    Julien's Avatar

    Hey Christophe,

    Definitely a good idea. I'll make "include drafts" an option. I'll keep you posted later this week.


  2. 2 Posted by Christophe on 03 Dec, 2014 02:40 PM

    Christophe 's Avatar

    Hi julien,

    Any idea on when you can implement and deploy this enhancement?


    From: Julien
    [mailto:[email blocked]]

  3. 3 Posted by Julien on 03 Dec, 2014 02:48 PM

    Julien's Avatar

    Hey Christophe.


  4. 4 Posted by Seb on 03 Dec, 2014 04:44 PM

    Seb 's Avatar

    Hi Julien,

    Thank you for your quick help, but I think there is a little bug, you need
    to check and uncheck the draft parameter to take the option into account.

    By default the check box is uncheck and draft article are still exported.



  5. 5 Posted by Julien on 03 Dec, 2014 06:10 PM

    Julien's Avatar

    Hey Seb,

    I was not able to reproduce this bug. What browser/platform is this on?


  6. 6 Posted by Seb on 04 Dec, 2014 11:12 AM

    Seb 's Avatar

    Hi Julien,

    Chrome (39) on PC. But i cannot reproduce it now.

    I checked the POST request header and the “include_drafts” parameter is
    sent only if you check it.

    Seems linked to cache issues J

    Thank you for your help.



  7. 7 Posted by Julien on 04 Dec, 2014 02:16 PM

    Julien's Avatar

    No worries. Cheers!

  8. Julien closed this discussion on 04 Dec, 2014 02:16 PM.

Discussions are closed to public comments.
If you need help with Tender please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac