Unable to set up GitHub issues ticket tracker

sreilly's Avatar


29 Mar, 2019 10:51 AM

I'm unable to fully set up a github ticket tracker on our site. The authentication and authorisation happens just fine and the tender setup page loads a list of repositories and asks to select the one to use. One strange thing is that it shows duplicate entries for many, but not all, of the repositories. I select the entry for either repository (neither works, I've tried both), select the "Shared" box, and then press Save Tracker and an error response is produced saying that you've been notified of the issue and will look at it shortly.

It's been nearly a day and I've seen others here with github issues problems with no response. Is this something we can get fixed soon?


  1. Support Staff 1 Posted by Courtenay on 03 Apr, 2019 10:20 PM

    Courtenay's Avatar

    Hi Sean, github has changed a few of their APIs and we're trying to get a fix in place for it.

  2. Support Staff 2 Posted by Courtenay on 10 Apr, 2019 12:34 AM

    Courtenay's Avatar

    This should be fixed now - you may need to edit or re-create the webhook linking github back to tender (if you want issue changes there to propagate and re-open discussions here). Instructions are at the link here: http://infinitekind.tenderapp.com/dashboard/trackers/3225

  3. 3 Posted by sreilly on 16 Apr, 2019 02:54 PM

    sreilly's Avatar

    Hi Courtenay,

    I'm sorry, but the issue still exists and I get the exact same error messages as described earlier.

    I am also unable to access the link you mentioned... it seems like it may be the Tender internal link rather than a publicly facing one?

  4. 4 Posted by sreilly on 16 Apr, 2019 03:10 PM

    sreilly's Avatar

    whoops, I just noticed that the link was to our own dashboard setting, which I had deleted. I am still having the same problem however.

  5. 5 Posted by sreilly on 16 Apr, 2019 03:26 PM

    sreilly's Avatar

    ok, it looks like it's running now, although I had to add it using an administrator github account. When using the non-admin account (which is preferable, for safety's sake) it showed the general error mentioned above. When using the admin account it progressed normally, even though I had to create the webhook myself, which is fine.

    Please feel free to close this request.

  6. brandi closed this discussion on 23 Apr, 2019 07:51 PM.

Discussions are closed to public comments.
If you need help with Tender please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac